ascode 1001 나는 차차를 싫어해!

최대 1 분 소요

문제 설명

나는 차차를 싫어해
문자열의 차가 2개 이상 있으면 모든 차를 없애줘!

입력 설명

첫 줄에 testcase의 갯수가 들어온다.
testcase만큼 문자열이 들어온다.
1<=문자열의 길이<=1024
대소문자를 구분하지 않는다.

출력 설명

들어온 문자열에서 char가 두 번 이상 나올 시 모든 char를 지우고 출력! (만약 출력할게 없으면 “I Hate CharChar!” 를 출력한다.)

입력 예시

4
iHatecharchar
charpoint
charpointchar
charcharcharcharcharchar

출력 예시

iHate
charpoint
point
I Hate CharChar!

코드

import re
a = int(input(''))
while(a):
    b = input('')
    if b.lower().count('char') >= 2:
        insensitive_hippo = re.compile(re.escape('char'), re.IGNORECASE)
        if insensitive_hippo.sub('', b) == '': 
            print("I Hate CharChar!")
        else :
             print(insensitive_hippo.sub('', b)
)
    else:
        print(b)
    a = a - 1

댓글남기기